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In this chapter you will learn:
• How to create and print tables
• How to create and print queries
• How to create and print forms
• How to create and print reports

Case: What SUP, Inc.
Kyle explains to Nathan, Meagan, and you that the key to understanding how
to create and use a database is to understand a database’s elements: tables,
queries, forms, and reports.
Tables store like information together. Once a table is designed with fields and
attributes, information is then collected into tables for later queries, forms, and reports.
Queries allow the database user to ask questions of the information stored in
tables. For example, a database user might want to know what inventory balances are for each item as of a particular date or how many units of a particular
item were sold to a particular customer.
Forms allow the database user to view, update, add, and delete information stored
in tables but organized in traditional forms or source documents like sales invoices,
inventory cards, purchase orders, and so forth. Change management experts agree
that users of databases prefer information presented in traditional formats even
though the raw data might be stored in a different manner (i.e., in tables).
Reports allow the database user to communicate information stored in the database in more usable formats. This might include sorting the information in a certain way—for example, from largest value to smallest value. It might also include
grouping the information in a certain way: by customer, salesperson, or product.
Finally, reports allow us to ‘‘filter’’ the information and so view only what is
needed; examples include sales for a particular month, inventory balances as of a
particular date, and accounts receivables for certain specified customers.
Kyle suggests you practice by creating some tables, queries, formats, and
reports for What SUP’s inventory system.

Tables
Step 1 in the creation of any database is developing an understanding of the
business and its information needs. Initially, this will take the form of table
199
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creation and separation. Rather than placing all information in one table, it’s
important to separate information into manageable ‘‘chunks,’’ or tables. In our
inventory example, What SUP has information about its products, product suppliers, and product categories that could be combined. However, since every
product has one supplier but some suppliers provide more than one product, a
one-to-many relation exists between suppliers and products. Likewise, every
product falls under one category, but most categories include many products.
Thus, we should separate product, supplier, and category information into three
separate tables with the common relationship being the supplier identification
(ID) number and category ID number.
Step 2 is deciding what information we need for each table, what form (or
data type) that information takes, and what properties exist for each field. This
means that, for each table (product, supplier, and category), we must identify
fields where information is to be stored. A common technique in database creation is to establish a unique ID number field for each record. This field will also
be identified as our Primary Key field, which by definition holds data that
uniquely identifies each record in a table. Thus, our first field, common to all
information entered into the table, is a product ID. Next would be a product
name, description, and so on. For each field, a corresponding data type (number, text, currency, etc.) must be established and, depending on the data type,
properties for each field must be identified (field size, format, caption, etc.).
Step 3 is inputting the information into the tables. This is where we gather
information about each product, supplier, and category. ‘‘How about running all
that by me one more time?’’ you ask.
‘‘I’ll do you one better,’’ responds Kyle. ‘‘I’ll let you watch me create the
product table.’’

Creating the Product Table
Kyle explains that—in addition to creating fields for a product ID, name, and
description—he will create fields that link the product to a specific inventory
category supplier and that identify the product’s serial number, unit price, reorder level, and required lead time.

To create the product table:
1 Start Access.
2 Click the File tab, then click New, and then double-click Blank desktop database to create a new database file.
3 Type ch9-01_student_name (replacing ‘‘student_name’’ with your
name, as before) into the File Name: text box as shown in Figure 9.1.
(In the figure, the file is being saved into the Documents folder on a
computer’s ‘‘C’’ drive in a folder called My Databases. You should
place your newly created file into a folder and drive you will be able
to access later. Do this by clicking the folder icon next to the text box
and navigating to your desired location.
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Figure 9.1
Creating a New Blank
Database

4 Click Create. A new blank database should open with a new
table and with the table tools showing in the ribbon, as shown in
Figure 9.2.

Figure 9.2
New Database Window

5 Click View and then click Design View.
6 Type Product Table as the name of the new table you are about to
create and then click OK.
7 Change the first field name from ID to ProductID, leaving the data
type as AutoNumber.
8 Enter the additional field information shown in Figure 9.3 exactly as
typed. (Note: Each data type has different field property characteristics, but all allow you to specify a caption. Be sure to separate the
field name for clarification and enter it as each field’s caption; see
Figure 9.3, Product ID, for an example.) Continue with the rest of the
fields, changing captions ProductName to Product Name, SupplierID
to Supplier ID, et cetera. Note: When adding field name Length as a
data type number you’ll need to specify the field size property as
Singe, and the decimal places property as 2.
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Figure 9.3
Product Table

9 Once you have entered all the field names, data types, and correct
captions, be sure that ProductID is designated as the Primary Key. If
it is not, select the field and then click the Primary Key tool from
the Tools group on the Design ribbon.
10 Click the File tab and then click Save.

You have created a placeholder for product information. Now it’s time to
create a placeholder for supplier information.

Creating the Supplier Table
As with the product table creation, once again several fields will be required to
capture information about each supplier. A supplier ID, supplier name, and contact name are just a few of the critical pieces of information necessary. In addition, Kyle suggests you should also include information about the contact’s
title, address, and phone and fax numbers.
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To create the supplier table:
1 Click the Create tab on the ribbon.
2 Click Table Design from the Tables group on the ribbon.
3 Enter the information shown in Figure 9.4 exactly as typed. (Note: Each
data type has different field property characteristics, but all allow you to
specify a caption. Be sure to separate the field name for clarification
and enter it as each field’s caption.) Continue with the rest of the fields,
changing SupplierName to Supplier Name, ContactName to Contact
Name, and so forth. (Observe that changing a field’s caption does not
change the field’s name.)

Figure 9.4
Supplier Table

4 Once you have entered all the field names, data types, and correct captions, click the SupplierID field name and then click the Primary Key
tool on the ribbon.
5 Click the File tab and then click Save.
6 Type Supplier Table as the table name in the Save As text box and
then click OK.
You have now created a placeholder for supplier information. All that is left
is to create a table with category information so that you can separate products
into identifiable categories.

Creating a Category Table
The final table necessary to complete the inventory database is a category table,
which will consist of only two fields: a category ID and a category name.
‘‘Why not just add the category to each product in the product table?’’ you ask.
‘‘Because,’’ Kyle responds, ‘‘in a relational database we try to conserve space
and eliminate redundancy.’’
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To create a category table:
1 Click the Create tab on the ribbon.
2 Click Table Design from the Tables group on the ribbon.
3 Create two fields: CategoryID as Short Text data type and
CategoryName as a Short Text data type.
4 Set the CategoryID field as the primary field
5 Click the File tab and then click Save and then type Category Table in
the Save As text box and then click OK.
Your table structure is complete. All you need now is information.

Entering Data into Tables
With the table structure complete, you volunteer to enter information about the
company’s products, suppliers, and categories. Nathan provides the information
for each category, product, and supplier.

To enter data into the three tables:
1 Double-click the Category Table.
2 Type A as the first Category ID and then type Flatwater as the first
Category Name. After you type each record, press the [Enter] key to
begin a new category.
3 Type additional categories as shown below in Figure 9.5.

Figure 9.5
Completed Category
Table

4 Close the Category Table window after you have typed all the
information.
5 Click Yes if asked to save changes.
6 Click the Supplier Table tab and then click View and then Datasheet
View from the Ribbon.
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7 Enter the information as specified in Table 9.1. After you type each
record, press the [Enter] key to begin a new supplier.

Table 9.1

Supplier Table Information

Supplier ID
Supplier Name
Contact Name
Contact Title
Address

1
Boardworks
Ben Nimitz
VP Sales
100 8th Ave.

2
Naish
Sara Munoz
Sales director
909 S. Washington

3
Bark
Nancy Bearfoot
Western sales
111 Macarthur Blvd.

4
Infinity
Paul Moo
Salesman
24382 Del Prado

City
Postal Code
State Or Province
Country
Phone Number
Fax Number

New York
10035
NY
USA
212-555-1354
212-555-6874

Pilot Pt.
76258
TX
USA
940-555-0817
940-555-1187

Mahwah
07430
NJ
USA
201-555-5730
201-555-3872

Dana Point
92629
CA
USA
949-555-4166
949-555-9718

5
Ron House
Kelly O’Leary
Regional sales
571 Mount
Pleasant
Dover
07801
NJ
USA
201-555-3215
201-555-8741

8 Close and save the Supplier Table after you have typed all the
information.
9 Double-click the Product Table.
10 Enter the information as specified in Table 9.2. After you type each
record, press the [Enter] key to begin a new product.
11 Close and save the Product Table window after you have typed all the
information.

‘‘Remember,’’ Kyle says, ‘‘in this case every product has one category, but every
category may have multiple products. Thus we have a one-to-many relationship.’’
Next up: establishing relationships among the three tables.

Establishing Table Relationships
One final step is necessary when you create multiple tables: creating relationships
between the tables. Recall our previous discussion (see Chapter 8) about one-toone, one-to-many, and many-to-many relationships. In the What SUP database
you created three tables, and now you must define each relationship. For example, every product belongs in a particular category and has a supplier. Thus, there
is a one-to-many relationship between the supplier table and the product table
and a one-to-many relationship between the category table and the product table.
Kyle suggests you establish those relationships using Access’s relationship tool.

To establish relationships between tables:
1 Select the Relationships tool from the Database Tools tab on the Ribbon.
2 Click each table in the Show Table window and click the Add button
so that all three tables appear in the Relationships window.
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12.5
2
A
NA321
800.00
2
11

Veneer
Raven
11.5
1
A
136305
700.00
5
10

Product
Name
Length
Supplier ID
Category
ID
Product
Number
Unit Cost
Reorder
Level
Lead Time

Nalu

14

500.00
2

137814

Shubu
X
10
1
B

103

101

Product ID

102

Product Table Information

10

625.00
2

NA841

Nalu
Air
10
2
B

104

GS233

Glide
GS
12.5
2
C

106

15

30

1,150.00 810.00
2
1

CA392

Candice
Appleby
12.5
3
C

105
Hollow
Carbon
14
5
C

108

30

690.00
2
25

110

514102

11
1
E

18

10

410.00
2

BD741

7
3
D

Joy Ride Badfish

109

1,700.00 626.00
2
2

ST23141 234

Slater
Trout
10
4
D

107

7

685.00
3

BD241

Badfish
2
9
3
E

111

8
2
F

Makani

113

12

975.00
1

3

135.00
10

CW94355 NA112

Clear
Wood
12.5
4
C

112

2

110.00
20

415333

BW
Hybrid
9
1
F

114
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3 Click Close in the Show Table window.
4 Resize the Product table and the Supplier Table so that all fields are
visible and the vertical scroll bars disappear, as shown in Figure 9.6.

Figure 9.6
Relationships Window

5 Click on the Category ID field in the Category Table. Hold the
mouse button down and drag to the Category ID field in the Product
Table, and then release the mouse button.
6 When the Edit Relationships window appears, click Create.
7 Click on the Supplier ID field in the Supplier Table. Hold the mouse
button down and drag to the Supplier ID field in the Product Table;
then release the mouse button.
8 When the Edit Relationships window appears, click Create. The Relationships window should now show lines connecting the common
fields between each table, as shown in Figure 9.7.
9 Click the Relationship Report tool in the Tools group of the Design
tab on the Ribbon. Click Open if a Microsoft Access Security Notice
appears.
10 Click Print and then click OK to print the relationships report.

Figure 9.7
Established Relationships

11 Close the Relationships report and click No when asked if you want
to save changes to the report.
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12 Close the Relationships window and click Yes if asked to save the
changes to the relationships.

Now that relations have been established, you can create queries, reports, and
forms that use information from one or more tables. However, it is always important to have a physical copy of your tables for backup and reference.

Printing Tables
Occasionally you may want to print the tables to make sure information has
been entered correctly. Later you will use the report feature of Access to print
specific information available in the tables in a format that more effectively provides the needed information.

To print all three tables:
1 Double-click the Category Table.
2 Click the File tab and then click Print and then click Print Preview
to view a reduced-size version of the table to be printed.
3 Click once in the table to zoom to a larger size. (Note: You may have
to move the scroll bars around to find the table to be printed.) Your
screen should look like Figure 9.8.
4 Click the Print button on the Print Preview tab to print a copy of the
table, and then click OK to print.
5 Click the Close Print Preview button and then close the Category
Table window.

Figure 9.8
Print Preview of the
Category Table
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6 Double-click the Product Table.
7 Click the File tab and then click Print and then click Print Preview
to view a reduced-size version of the table to be printed.
8 Click the Print button on the Print Preview tab to print a copy of the
table, and then click OK to print.
9 Click the Close Print Preview button and then close the Product
Table window.
10 Double-click the Supplier Table.
11 Click the File tab and then click Print and then click Print Preview
to view a reduced-size version of the table to be printed.
12 Click the Print button on the Print Preview tab to print a copy of the
table, and then click OK to print.
13 Click the Close Print Preview button and then close the Supplier
Table window.

Queries
Queries are essentially questions about the information stored in the database,
such as: What products do we sell? From whom do we buy products? For any
query, it is important to identify where the information can be found, what information is required, what criteria have been established, and how the information is reported.

Creating a Query
Kyle explains that, for each query, tables are identified that contain the information to be requested. He suggests you create a query to list all products. Specifically, he wants you to provide the category name, product name, unit price,
supplier name, and supplier phone number.

To create a query:
1 Click the Create tab on the Ribbon.
2 Click Query Wizard from the Queries group on the Create tab.
3 Select Simple Query Wizard from the New Query window and then
click OK. Click Open if a Microsoft Access Security Notice appears.
4 Select Table: Category Table from the Table/Queries drop-down list.
5 Click the field Category Name from the list of available fields, then
click the > button. This action will place the field CategoryName into
the list of selected fields; see Figure 9.9.
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Figure 9.9
Simple Query Wizard

T r o u b l e ? If you select the wrong field or click the wrong buttons, you can use the > or < buttons to move fields back and forth
between the list of available fields and the list of selected fields.
6 Select Table: Product Table from the Table/Queries drop-down list.
7 Click the field Product Name from the list of available fields, then
click the > button. This action will place the field ProductName into
the list of selected fields.
8 Click the field Unit Cost from the list of available fields, then click
the > button. This action will place the field UnitCost into the list of
selected fields.
9 Select Table: Supplier Table from the Table/Queries drop-down list.
10 Click the field Supplier Name from the list of available fields, then
click the > button. This action will place the field SupplierName into
the list of selected fields.
11 Click Next in the Simple Query Wizard window.
12 Make sure the Detail button is selected in the window presented, and
then click Next.
13 Type Products Query as the title, click the Open the query to view
information button, and then click Finish.
14 The resulting query lists all products, as shown in Figure 9.10.
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Figure 9.10
Products Query

Printing a Query
Occasionally you may want to print the query to make sure information has
been properly selected. Later you will use the report feature of Access to print
specific information available from a query in a format that more effectively
provides the needed information.

To print a query:
1 Double-click Products Query.
2 Click the File tab and then click Print and then click Print Preview to
view a reduced-size version of the query to be printed.
3 Click the Print button on the Print Preview tab to print a copy of the
table, and then click OK to print.
4 Click the Close Print Preview button, and then close the Products
Query window.

Access has another helpful feature, called forms, for capturing or viewing information in a database.

Forms
Forms have a variety of purposes. One purpose is to provide a dialog box for
access to predesigned queries, other forms, or reports. Another purpose is to
provide a dialog box to capture new information and use it to carry out an
action.
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Creating a Form
Kyle suggests that you use a form to capture information about additional What
SUP’s products. He reminds you that entering information into a form automatically updates the table containing such information. The form itself is just a
means to update the table either by editing existing information or by adding
new information like a new record.

To create a form to capture additional products:
1 Click the Create tab on the Ribbon.
2 Click Form Wizard
3 Select Table: Product Table from the Table/Queries drop-down list.
4 Click the >> button to select all the fields available, and then click
Next.
5 Select the Columnar layout, and then click Next.
6 Type Product Form as the new form title, and then click Finish. The
resulting form should look like Figure 9.11.
7 Do not close this form.

Figure 9.11
Products Form

Next record button

New record button
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Using a Form to View, Edit, or Add Information
This newly created form can be used to enter new information, edit existing information, and view existing information for each product. Nathan offers to try
out the new form by viewing each record. He also volunteers to enter a new
product and edit a reorder level for one product.

To use a form to view and edit existing products and add
an additional product:
1 Click the Next record button (the right arrow) at the bottom of the
Products form and view each product. Continue to view each record
until you reach record 5, Product ID 105.
2 Click in the Reorder Level edit box and change the reorder level from
2 to 3.
3 Click the New record button (the right arrow with the asterisk).
4 Click in the Product Name field.
5 Type 115 as the Product ID and then type Blaster as the Product
Name.
6 Complete the form as shown in Figure 9.12.

Figure 9.12
Product Form with New
Record

Previous record button

7 Do not close this form.
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Nathan has completed the form and, in so doing, has edited an existing record and added a new one. This new product is now a part of the product table
and will be present for future queries or reports. Most of the information in a
form comes from an underlying record source. For What SUP this includes
some of the product information derived from the product table. Using graphical
objects called controls, Nathan created a link between the form and its record
source, the product table. He used the most common type of control used to display and enter data: a text box.
Other information in the form is stored in the form’s design. In the What
SUP form just created, this includes the descriptive text (such as headers and
footers) as well as graphic elements (such as the horizontal rule). In other forms
this might include a calculation that comes from an expression stored in the
form’s design.

Printing a Form
Occasionally you may want to print a single form.

To print a single form:
1 Click the Previous record button until you reach Record 2.
2 Click the File tab, click Print, and then click Print again.
3 Click Selected Record(s) to print the form of record 2. Note that only
record 2 will be printed, because you were in record 2 when you
activated the Print window.
4 Click OK to print the selected record.
5 Close the Products form.

‘‘How do I get a report of the information in my new database?’’ asks Nathan.
‘‘Good question,’’ Kyle answers. ‘‘Let’s generate a report for you now.’’

Reports
Reports are a way for a user to get information out of a database in a format
that helps the analytical process. To be useful, reported information needs to be
properly formatted, sorted, and/or grouped. Reports are more than listings of information. For instance, a user may want to create mailing labels, which would
require a different level of formatting than a report of items grouped in particular
categories. Your report may need a chart, a logo, subtotals, or grand totals. It
may need a date, a special title, headers and footers by item or category, et cetera.
Finally, your requirements may necessitate the reporting of only certain items in
your database that meet specific criteria, such as those items that cost more than
a certain dollar amount or those items from a particular category only.
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Creating a Report
Kyle suggests that your first report utilize Access’s Reports Wizard and simply
list, by product number, all the products together with their product ID, product
name, and unit price. There are five steps to creating a report:
•

Identify which fields you want in your report and in what tables those fields
are present.

•

Specify grouping levels, if any.

•

Specify sort order, if any.

•

Specify a report layout.

•

Specify a report style.

To create a report of all products listed by product number:
1 Click the Create tab on the Ribbon.
2 Click Report Wizard from the Reports group. Click Open if a
Microsoft Access Security Notice appears.
3 Click Table: Product Table from the list of Tables/Queries.
4 Click Product ID from the list of Available Fields; then click the
> button to move ProductID from the list of Available Fields to the
list of Selected Fields. Your screen should look like Figure 9.13.

Click here to add
selected fields to
the new report

Figure 9.13
Report Wizard
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5 Click Product Name from the list of Available Fields, then click the
> button to move ProductName from the list of Available Fields to
the list of Selected Fields.
6 Click Unit Cost from the list of Available Fields, then click the
> button to move UnitCost from the list of Available Fields to the list
of Selected Fields.
7 Click the Next button.
8 Click the Next button again, since no grouping is required for this report.
9 Select Product ID in the first sort order list box. Make sure the sort
order is Ascending, as shown in Figure 9.14, and then click Next.
10 Click Tabular Layout, Portrait Orientation, and make sure the
Adjust the field width so that all fields fit on a page check box is
checked; then click Next.
11 Type Products by Product ID as the name of the report. Select the
Preview the Report option button, and then click Finish. Your
window should look like the one shown in Figure 9.15.
12 Click Close Print Preview to reveal the report’s design view, as
shown in Figure 9.16.
13 Leave the resulting report design view window open.

Click here to select sort order

Figure 9.14
Selecting the Sort Order for a New Report
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Figure 9.15
Product Report

Figure 9.16
Design View

Editing a Report
You can edit this report at any point and change its characteristics. When you
closed the Report window, a Design View window appeared. You can switch
between Report, Layout, and Design view by clicking on the View tool.
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The Design view gives you a more detailed view of the structure of your
report. You can see the header and footer bands for the report, page, and groups.
The report is not actually running in Design view, so you cannot see the underlying data while working; however, there are certain tasks you can perform more
easily in Design view than in Layout view. You can add a wider variety of controls to your report, such as labels, images, lines, and rectangles. You can also
edit text-box control sources in the text boxes themselves (without using the property sheet) and change certain properties that are not available in Layout view.
The Layout view is the most intuitive view to use for report modification,
and it can be used for nearly all the changes you would want to make to a
report in Office Access 2013. In Layout view the report is actually running, so
you can see your data much as it will appear when printed. Nonetheless, you
can still make changes to the report design in this view. Because you can see
the data while you are modifying the report, it’s a useful view for setting column widths, adding grouping levels, or performing almost any other task that
affects the appearance and readability of the report.
Meagan suggests that the report just generated could be improved be centering the product ID title and data, narrowing the width of the unit price field,
and narrowing the horizontal rule. You offer to make the changes she has suggested by using the Design view.

To edit the ‘‘Products by Product ID’’ report:
1 Change to the Layout view by clicking the View button tool and
clicking Layout View. Note the differences between the Layout view
shown here in Figure 9.17 below and the Design view shown
previously in Figure 9.16. (More on this later.)

Figure 9.17
Layout View
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2 Change back to the Design view by clicking the View button tool and
clicking Design View.
3 Click Product ID (located in the Page Header section), then click the
Center tool in the Text Formatting group in the Home tab of the
Ribbon.
4 Click Product ID (in the Detail section) and then click the Center
tool.
5 Click ProductName (in the Page Header section). Hold the Shift key
down and click ProductName in the Detail section as well. (Note:
Holding the Shift key down allows you to select both the header and
the detail field at the same time.)
6 Click the right side on the ProductName field and drag to the left until
the rightmost edge of both the ProductName field and header are lined
up with the 3-inch marker on the ruler. Repeat the same process for
the UnitCost field and header so that they are lined up as shown in
Figure 9.18.

Figure 9.18
Resizing Fields in a Report

7 Click anywhere in the Report window to unselect the Unit Cost fields.
8 Scroll to the far lower right-hand side of the report and then click the
Pages text box located in the Page Footer.
9 Click the right side of the Pages text box and drag to the left until the
rightmost edge of text box is lined up with the 5½-inch marker on the
ruler.
10 Click the right side of the report and drag to the left until the rightmost
edge of the report is lined up with the 6-inch marker on the ruler.
11 Click the View tool and then click Report View to see the effects of
these changes on the final report. Your report should now look like
Figure 9.19.
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Figure 9.19
Resized Report in Print
Preview

12 Close the Products by ProductID report.
13 When prompted, click Yes to save the changes in the Products by
ProductID report.

Printing a Report
Often you will want to print the reports created.

To print the ‘‘Products by Product ID’’ report:
1 Double-click the Products by Product ID report.
2 Click the File tab, click Print, and then click Print Preview.
3 Click the Print button and then click OK to print the report. Your
report should look like Figure 9.20.
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Figure 9.20
Printed Products by
Product ID Report

4 Close the Products by ProductID report window.

Nathan and Meagan are both pleased with your changes and impressed with
your skills. They recognize that they have just scratched the surface of what
Access can do for their business and are anxious to learn more.

End Note
In this chapter you have learned about some basics of the Access program,
some features of the help system, and how to work with tables, queries, forms,
and reports. There is much more to the Access program and much more to
know about tables, queries, forms, and reports. The following four chapters will
elaborate on each of these, bringing you a keener understanding of how Access
is used in accounting.
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